eclipse regression

Mark Wielaard mark at klomp.org
Fri Mar 3 10:29:08 UTC 2006


Hi Christian,

On Fri, 2006-03-03 at 01:49 +0100, Christian Thalinger wrote:
> I'm unable to install some (any?) plugins in eclipse with CVS head.  I
> already talked to tashiro on irc and it works with 0.20 release.  The
> problem is in two places:
> 
> * Software Updates - Find and install says: "Current configuration
> problems"
> 
> * Software Updates - Manage Configuration does not allow to open
> "Eclipse SDK", it only shows this entry.
> 
> I hope i made myself clear (it's rather late).

Yep. I am seeing the same thing. I was trying out
http://developer.classpath.org/mediation/ClasspathHackingWithEclipse
from scratch and trying to install the CDT plugin and it fails as you
describe above. 

I haven't figured out since when this stopped working, but it clearly is
a regression. If you installed the feature with a working version of
classpath (0.20) and then try to use it with a CVS version you will get
messages like:
!ENTRY org.eclipse.update.configurator 2006-03-03 11:19:10.787
!MESSAGE Unable to parse file
"/tmp/eclipse/plugins/org.eclipse.cdt.core_3.0.2/plugin.xml".

So I guess it is something going wrong with the parsing of xml files.
But I haven't found the point yet where eclipse does this, or what the
actual error is that occurs.

Cheers,

Mark
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://developer.classpath.org/pipermail/classpath/attachments/20060303/603ba4b1/attachment-0001.pgp


More information about the Classpath mailing list