New gmp/mpfr on builder (Was: [cp-testresults] FAIL: gcc build on Tue Jul 22 09:36:17 UTC 2008)

Mark Wielaard mark at klomp.org
Tue Jul 22 13:56:57 UTC 2008


Hi,

Recent gcc/gcj builds on builder failed with:

On Tue, 2008-07-22 at 09:36 +0000, cpdev at builder.classpath.org wrote:
> checking for correct version of mpfr.h... no
> configure: error: Building GCC requires GMP 4.1+ and MPFR 2.3.0+.
> Try the --with-gmp and/or --with-mpfr options to specify their locations.
> Copies of these libraries' source code can be found at their respective
> hosting sites as well as at ftp://gcc.gnu.org/pub/gcc/infrastructure/.
> See also http://gcc.gnu.org/install/prerequisites.html for additional info.
> If you obtained GMP and/or MPFR from a vendor distribution package, make
> sure that you have installed both the libraries and the header files.
> They may be located in separate packages.

Which is a newer version than Debian stable had available. So, I took
the source packages from Debian testing, rebuild and installed those on
builder.

Cheers,

Mark

$ dpkg -s libgmp3-dev libmpfr-dev
Package: libgmp3-dev
Status: install ok installed
Priority: optional
Section: libdevel
Installed-Size: 1388
Maintainer: Steve M. Robbins <smr at debian.org>
Architecture: i386
Source: gmp
Version: 2:4.2.2+dfsg-3
Replaces: libgmp2-dev
Depends: libgmp3c2 (= 2:4.2.2+dfsg-3), libgmpxx4ldbl (= 2:4.2.2+dfsg-3)
Recommends: libstdc++-dev
Suggests: libgmp3-doc, libmpfr-dev
Conflicts: libgmp2-dev
Description: Multiprecision arithmetic library developers tools
 This development package provides the header files and the symbolic
 links to allow compilation and linking of programs that use the libraries
 provided in the libgmp3 package.
 .
 Both C and C++ bindings are present in this package.  Package
 libstdc++-dev is required to use the C++ bindings.
 .
 The MPFR library (multiple-precision floating-point) used to be
 included, but has since been moved to package libmpfr-dev.

Package: libmpfr-dev
Status: install ok installed
Priority: optional
Section: libdevel
Installed-Size: 804
Maintainer: Laurent Fousse <laurent at komite.net>
Architecture: i386
Source: mpfr
Version: 2.3.1.dfsg.1-2
Replaces: libgmp3-dev (<< 4.1.4-3)
Depends: libgmp3-dev (>= 4.2.dfsg-1), libmpfr1ldbl (= 2.3.1.dfsg.1-2)
Conflicts: libgmp3-dev (<< 4.1.4-3)
Description: multiple precision floating-point computation developers tools
 This development package provides the header files and the symbolic
 links to allow compilation and linking of programs that use the libraries
 provided in the libmpfr1ldbl package.
 .
 MPFR provides a library for multiple-precision floating-point computation
 with correct rounding.  The computation is both efficient and has a
 well-defined semantics. It copies the good ideas from the
 ANSI/IEEE-754 standard for double-precision floating-point arithmetic
 (53-bit mantissa).
 .
 The home page is http://www.mpfr.org/.





More information about the Classpath mailing list